티스토리 뷰

먼저 3.4 환경을 맞춰야한다.


mac 10.11


python 을 3.4로 다운 받는다


$ conda update conda 

## 다운 가능한 리스트를 업데이트 하는듯하다. 

## 리눅스에서 apt-get update 와 비슷한 역활을 하는듯


$ conda create -n python3.4 python=3.4 anaconda

# python3.4라는 폴더를 만들고, python3.4버전 베이스로 한 ananconda를 받는다.

# ENV name은 'python3.4'가 된다.


$ source activate python3.4

#ENV name이 python3.4인 놈으로 활성화

# 이명령어가 정상적으로 수행되면 쉘앞에 (python3.4) ..... $식으로 붙는다.


$ set PATH=/ananconda/env/python3.4/bin:${PATH}

# 경로 추가. 설치된 경로를 넣어주자.

# .bash_profile 안에다가.

# alias set34='source activate python3.4; set PATH=/ananconda/env/python3.4/bin:${PATH}'

# 와 같이 추가하여서 위의 과정을 간략화하는 것도 좋다.



2. zipline 설치

방법1. 

$ pip install zipline


방법2

https://wikidocs.net/4428

댓글에 보면 이런 내용이 있다.


$현재(2016/09/06)는 Quantopian에서 zipline을 conda로 간편하게 설치하는 방법도 제공되고 있습니다.(https://github.com/quantopian/zipline/ 참조)

아나콘다에서 python 3.4로 env를 맞추고 conda install -c Quantopian zipline 커맨드를 실행하니 Visual C++ 설치 없이도 zipline이 정상 작동합니다. 저는 Ubuntu 14.04 LTS 64bit를 사용하고 있기는 한데, Windows/Mac OS/Linux 64비트를 모두 지원한다고 하니 오류가 나시는 분들은 conda install -c Quantopian zipline을 시도해보시는 것도 괜찮을 것 같습니다. - Younghun, 2016년 9월 6일 3:20:47 오후

신고
댓글
댓글쓰기 폼